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There’s so much to like about the easy-

to-maneuver, family-friendly Aluma-Lite 

Class C. But don’t be fooled by its size. 

This snappy Class C is a paradox of sorts, 

with jumbo-sized features packed into a 

less than jumbo package. A king-size fresh 

water tank allows for extended camping 

opportunities, along with an extra large 

exterior bay that stores all equipment in 

a central, convenient location. Oversize 

features inside include a 42-inch-by-18-

inch galley space accented by a 48-inch-

by-36-inch dinette window. A substantial 

wardrobe provides valuable expanded 

storage. Available in 23, 28 and 31-foot 

floorplans, the Aluma-Lite Class C provides 

a smaller, more agile RV with big features 

and competitive fuel economy at an 

affordable price. (Pictured: 23RB/Turning Leaves/

Newport Cherry)  
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ALL ROADS LEAD TO HOLIDAYRAMBLER.COM

Wherever the road takes you, you’re never more than a click away from your 

friends at Holiday Rambler. Just go to holidayrambler.com for all the latest 

product news, club dates and destinations, a dealer locator function, and factory 

tour information. You can also e-mail us directly through the site at any time.

bUy locally. eNJoy eVeryWhere.

Holiday Rambler strongly encourages its retail customers to purchase from their local dealerships whenever 

possible. Buying a new Holiday Rambler RV locally allows a customer to establish a relationship with a dealer close 

to home and provides convenient service and support from product-trained technicians. On our end, Holiday 

Rambler will continue to provide our dealer partners and customers with the finest RVs in the industry. 
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28PBS 31SFD 31WBS

The actual overall length of the recreational vehicle may differ from 
that indicated in the brochure due to variances in the manufacturing 
process and/or installed components. The actual length may 
be greater or less than that indicated. Due to the large variety of 
options and floorplan arrangements available to our customers, 
actual weights for each unit can differ significantly. Holiday Rambler 
provides a weight sticker on each unit we produce which includes 
that unit’s tank capacities and approximate weight. Consult your 
local Holiday Rambler dealer for unit availability and further 
information. The information printed in this brochure reflects 
product design, fabrication, and component parts at the date of 
printing. The manufacturer reserves the right, at any time, to make 
changes in product design or material or component specifications 

as its sole option, without notice. This includes the substitution of 
components of a different brand or trade name which will result in 
comparable performance. All information printed in this brochure is 
subject to change after the date of printing. Some features shown or 
mentioned in this brochure are optional and may only be available 
in selected floorplans. Photographs may depict a floorplan option 
that has been discontinued or is no longer available at the time of 
your purchase. Photographs may show props or decorations that 
are not standard equipment. Holiday Rambler, the Holiday Rambler 
logo and its design, are registered trademarks. Other products 
and company names are trademarks and/or registered trademarks 
of their respective holders. While the color of the motorhome’s 
exterior and the interior fabrics depicted in this sales brochure are 

fair and reasonable depictions, the colors depicted may not be an 
exact match of the actual colors because of the variances in photo-
processing and printing. Due to product improvements, changes 
during the model year and/or transcription errors that may occur, 
information represented within this brochure may not be accurate 
at the time of your purchase. If certain information is significant 
to your purchasing decision, please confirm the information with 
your dealer. Component part and appliance manufacturers issue 
limited warranties covering portions of the recreational vehicle not 
covered under the Limited Warranties issued by Monaco RV, LLC. To 
learn specific details regarding warranty coverage, please contact 
your selling dealership or review the warranty packet inside the 
recreational vehicle.

1Towing capacity is limited by GCWR; your vehicle’s towing capacity 
is the difference between the GCWR and the actual vehicle weight, 
including all water, fuel, passengers and cargo. Your towed vehicle 
should be equipped with auxiliary brakes if the weight of the towed 
vehicle exceeds 1,000 lbs. Consult your owner’s manual for further 
towing information.

2All tank capacities are estimated based upon calculations provided 
by the tank manufacturers and represent approximate capacities. The 
actual “usable capacity” may be greater or less than the estimated 
capacities based upon fabrication and installation of the tanks.

3Actual filled LP capacity is 80% of listing due to safety shut-off 
required on tank.

Due to continuous product improvement, visit  holidayrambler.com  for the latest in standards and options, specifications, and technical data.

AROUND-THE-CLOCK SERVICE AND SUPPORT 
When you take delivery of your new RV, it’s just the beginning of our exclusive around-the-clock Owner 
Advantage Program. We offer an extensive support program that provides complete roadside assistance 
and special motor club benefits that follow you wherever your travels take you. We’ve teamed up with 
the largest RV emergency road service company in the country to give you immediate access to fast, 
dependable service when and where you need it. Add our toll-free service appointment assistance, plus 
a technical assistance hotline, and you have the security of full-time support at your fingertips.

For details, call toll-free (877) 211-8135
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body construction
Laminated Sidewall with Fiberglass Skin ›
Laminated Roof, Seamless Rubber Roof, Lauan,  ›
Aluminum Frame with Foam, and Hard Interior Ceiling 
Board (Non-Ducted AC) (23RB)
Laminated Roof, Seamless Rubber Roof, Lauan,  ›
Aluminum Frame with Foam, and Hard Interior Ceiling 
Board (Ducted AC) (N/A: 23RB)
Mega Storage Under Bed with Two Exterior Storage  ›
Doors at Sidewall and Rear Wall (23RB Only)
Pass-Through Storage Under Bed with Two Exterior  ›
Storage Doors at Each Sidewall (31SFD)
Large Storage Under Bed with Three Exterior Storage  ›
Doors at Each Sidewall and Rear Wall (28PBS, 31WBS)
Hardboard Vinyl Ceiling ›
Front Radius Cap Profile ›
Deluxe Breakaway Exterior Mirrors ›
Daytime Running Lights ›
Integrated Rear Bumper ›
Rear Ladder ›
Double Entry Steps with Battery Storage Under Step ›
Rear Wheel Mudflaps ›
Deluxe Graphics Package ›
Aluminum Running Boards ›

ford chassis/engine (gas)/suspension
Ford E350 Chassis (23RB) ›
Ford E450 Chassis (N/A: 23RB) ›
6.8L Triton › ® V-10 Gasoline Engine w/ Sequential 
Electronic Fuel Injection; 305 HP @ 4,250 RPM / 420 
lbs./ft. Torque @ 3,250 RPM
5-Speed TorqShift › ® Automatic Transmission w/ 
Overdrive; In-Tank Oil Cooler
115 Amp Alternator ›
Rear Axle Ratio 4.10:1 (E350 Chassis)  ›
Rear Axle Ratio 4.56:1 (E450 Chassis) ›
Radial Tires with Stainless Steel Wheel Covers ›
Hellwig › ® Helper Springs (28PBS, 31SFD, 31WBS)
ABS Brake System ›
One 12V Chassis Battery ›
5,000 lb. Hitch Receiver with 7-Pin Connector ›
Emergency Start Circuit ›

chevy chassis/engine (gas)/suspension
Chevy 3500 Chassis (23RB) ›
Chevy 4500 Chassis (N/A: 23RB) ›
Vortec 6.0L V-8 Sequential Fuel Injection; 300 HP @  ›
4,400 RPM / 360 lbs./ft. Torque @ 4,000 RPM
4-Speed Auto Heavy-Duty Transmission; Electronically- ›
Controlled w/ Overdrive; Internal Trans. Oil Cooler
145 Amp Alternator ›
Rear Axle Ratio 4.10:1 ›

Radial Tires with Stainless Steel Wheel Covers ›
Rear Mult-Leaf Spring Suspension w/ Stabilizer Bar ›
Hellwig › ® Helper Springs (28PBS, 31SFD, 31WBS)
ABS Brake System ›
One 12V Chassis Battery ›
5,000 lb. Hitch Rec with 7-Pin Connector ›
Emergency Start Circuit ›

cockpit
In-Dash AM/FM Stereo with Clock ›
Dual Air Bags ›
Multi-Positioned Sun Visors ›
Windshield Privacy Curtain ›
Fabric Reclining Cockpit Seats ›
Dash Heating and AC System with Defrost ›
Power Door Locks and Windows ›
Factory AC, Cruise Control and Tilt Steering Wheel ›
Intermittent Windshield Wipers ›

appliances and accessories
Large Double-Door Refrigerator ›
3-Burner Cooktop  ›
Lighted Power Range Hood ›
Built-In Microwave ›
26" LCD TV in Living Area (31WBS Only) ›
26" LCD TV at Dinette Location with Lift (31SFD Only) ›
32" LCD TV in Living Area (28PBS Only) ›
Exterior Hookups for DSS Dish and Cable ›
TV Antenna ›
Interior Cable TV Hookup ›
Systems Monitor Panel: Battery Levels, Holding Tank  ›
Levels and Water Pump Switch

interior
Newport Cherry Cabinetry ›
New-Style Overhead Cabinets w/ Square Raised-Panel  ›
Cabinet Doors
Wood Grain Panel Refrigerator Insert ›
Laminate Kitchen and Bath Countertops with Wood  ›
Grain Edge
Kitchen Countertop Extensions ›
Ball Bearing Drawer Glides in Kitchen ›
Laminate Dinette Tabletop with Wood Grain Edge ›
Linoleum Throughout ›
Mirror Wardrobe Doors ›
Medicine Cabinet w/ Mirror in Bathroom ›
Bedspread with Reverse Shams ›
Wood Arched Headboard w/ Accent Panel Insert ›
Mini Blinds Throughout ›

furniture
Queen Bed (N/A: 23RB) ›

Queen Bed w/ Angled Corner at Foot (23RB Only) ›
Cab-Over Bunk Mattress ›
Fabric Jackknife Sofa (N/A: 23RB) ›
Fabric U-Shape Booth Dinette ›

electrical systems and lights
30 Amp 120V Distribution Panel ›
Detachable 30 Amp Power Cord ›
55 Amp 12V Power Converter ›
Gasoline Generator ›
Battery Disconnect Switch ›
12V House Battery ›
Exterior Storage Lights ›
Porch Light/Security Light ›
Interior Water Heater Switch ›
Patio-Side 120V Exterior Receptor/Cable TV Hookup ›
Interior Ceiling Light Switches ›

plumbing and lp systems
Large Double Bowl Stainless Steel Kitchen Sink and  ›
High-Rise Faucet
Stainless Steel Bath Lavatory Bowl ›
6-Gallon LP Gas Water Heater ›
12V Water Pump ›
City Water Hookup ›
Water Heater Bypass Valve ›
Rectangle Tub with Tub/Shower (23RB) ›
Rectangle Shower (31WBS) ›
Vinyl Shower Curtain (23RB, 31WBS) ›
Neo-Angle Shower w/ Glass Door (31SFD Only) ›

heating, vents and ac
13,500 BTU AC in Living Area ›
Front Cab-Over, Kitchen Manual Roof Vents ›
Bedroom Manual Roof Vent (N/A: 23RB) ›
12V Power Roof Vent in Living Area ›

windows, doors and awnings
Exterior and Interior Entry Assist Grab Handles ›
Tinted Radius Corner Windows ›
Skylight in Bathroom ›
Patio Awning ›
Topper Slideout Awnings (N/A: 23RB)  ›

safety
Fire Extinguisher ›
Deadbolt Lock on Entrance Door ›
GFI Circuit ›
LP Gas/Smoke/Carbon Monoxide Detectors ›
Pilot/Copilot 3-Point Seat Belts                                           ›

Standards Options

body construction
Power Heated Exterior Mirrors ›
Fiberglass Running Boards ›
High Gloss Fiberglass Sidewalls ›
Lower Paint Package ›
Mega Storage Lid Covers (23RB Only) ›
Large Storage Lid Covers w/ two Folding Tables  ›
(31WBS Only)
Chassis Undercoating ›

ford chassis/engine (gas)/suspension
Spare Tire  ›
Stainless Steel Wheel Inserts ›
Valve Stem Extenders ›

chevy chassis/engine (gas)/suspension
Spare Tire  ›
Stainless Steel Wheel Inserts ›
Valve Stem Extenders ›

cockpit
Power Pilot Seat (N/A: 23RB) ›
Leatherette Cockpit Seats ›

In-Dash AM/FM/CD Stereo Radio; Sirius Ready  ›
Compatibility, SD Card Slot, USB Port for MP3 Player/
Flash Drives, and Weather Band; LCD Back-Up 
Camera Monitor System w/ DVD Player
Instrument Panel Appliqué ›
Cab-Over Bunk Ladder ›

appliances and accessories
3-Burner Range with Oven ›
Black Folding Range Cover ›
Convection Microwave ›
Home Theater Surround Sound System w/ Sub-Woofer  ›
(Requires Option Selection of Back-Up System and 
Stereo with DVD Player)
Ext. Entertainment Center, CD w/ Radio, 2 Speakers ›
26" TV Option with Standard Cab-Over Sleeping ›
Inside/Outside 26" LCD TV w/ Mounting Brackets and  ›
Hookups (Bedroom and Exterior Under Patio Awning)
19" LCD TV in Bedroom ›

interior ›
Décors: Turning Leaves, Mint Condition ›
Fulton Cherry Wood Option ›
Newport Cherry Glaze on Cabinet Doors ›

Night Shades ›
Hardwood Raised Panel Refrigerator Front ›

furniture
Leatherette Hide-A-Bed Sofa (31WBS Only) ›
Leatherette Jackknife Sofa (N/A: 23RB) ›
Leatherette U-Shape Booth ›

electrical systems and lights
Second Coach House Battery ›
Onan › ® 4.0 kW Generator w/ Auto Changover

plumbing and lp systems
6-Gallon Gas/Electric Water Heater w/ DSI ›
Outside Shower ›
Glass Shower Door (N/A: 31SFD) ›

heating, vents and ac
15,000 BTU Air Conditioner in Kitchen ›
Holding Tanks with Heat Pads ›
Front Cab-Over Fantastic Fan Roof Vent ›

windows, doors and awnings
Electric Patio Awning ›

WarraNTieS
12 month/24,000 mile basic limited warranty. 5 year/50,000 mile limited structural warranty. *Review your coach’s limited warranty in full 
for complete terms and conditions. Review your chassis manufacturer’s limited warranty in full for complete terms and conditions.

23RB

 Gross Vehicle Weight Rating (Lbs.)  11,500 14,500 14,500 14,500

 Gross Combined Weight Rating 1  (Lbs.) 18,500 20,000 20,000 20,000

 Front Gross Axle Weight Rating (Lbs.) 4,600 5,000 5,000 5,000

 Rear Gross Axle Weight Rating (Lbs.) 7,800 9,500 9,500 9,500

 Grey Tank (Gal.)  33 TBD 26 26

 Grey Tank Kitchen (Gal.)  N/A N/A 24 24

 Black Tank (Gal.)  35 TBD 26 26

 Fresh Tank (Gal.)   61 TBD 51 51

 Fuel Tank | FORD/CHEVY (Gal.)   40/TBD 55/TBD 55/TBD 55/TBD

 LP Tank (Gal.)  42 42 42 42

 Gross Vehicle Weight Rating (Lbs.)   12,300 14,050 14,050 14,050

 Gross Combined Weight Rating 1  (Lbs.)  16,000 17,600 17,600 17,600

 Front Gross Axle Weight Rating (Lbs.)  4,600 4,600 4,600 4,600

 Rear Gross Axle Weight Rating (Lbs.)  8,300 9,450 9,450 9,450

 Wheelbase | FORD  160" 191" 223" 223"

 Wheelbase | CHEVY  TBD TBD TBD TBD

 Overall Length w/o Ladder/Spare Tire | FORD   23' 11" TBD 31' 11" 32' 4"

 Overall Length w/o Ladder/Spare Tire | CHEVY  TBD TBD TBD TBD

 Overall Height, Including AC  10' 8" 10' 10" 10' 10" 10' 10"

 Interior Height  82" 82" 82" 82"

 Interior Width  96" 96" 96" 96"

 Exterior Width  100" 100" 100" 100"



STRONGER THAN EVER.
When you buy a new Holiday Rambler, you get all the great 

things you expect: state-of-the-art products, innovative 

floorplans and first-class customer service. You also get the 

confidence that comes with being part of a 175-year-old parent 

company like Navistar, a world leader in transportation. To learn 

more about Navistar and its affiliates, visit navistar.com.

91320 Coburg Industrial Way, Coburg, OR 97408   |   holidayrambler.com   |   800 245 4778
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